Alpaca UI dashboard not showing updated orders

Hi guys,

I am using a paper trading account and have purchased multiple orders using the following Python code.

order = self.api.submit_order(symbol, qty, side, type, time_in_force)

The orders seem to be going through because when I run the following code:

accountInfo = self.api.get_account()

The buying power and cash go down each time I submit an order (after I print out updated info on my terminal window).

But when I refresh the paper trading dashboard it doesn’t show the new orders in the “order history” section I just bought . The updated cash and buying power do not update also.

Why is the dashboard on the alpaca website not updating?

It is also important to note that my orders seem to be in the accepted stage. Could this be the reason? It says this stage is very rare according to the following definition on the alpaca website:

Accepted The order has been received by Alpaca, but hasn’t yet been routed to the execution venue. This state only occurs on rare occasions.

Thank you

Hi soccerfp,
The market must be open for those to move past accepted.

I see it’s your first post, welcome to Alpaca!

1 Like

Hi @synchronicity, @soccerfp
I’m facing the same issue, orders are at “accepted” state…
BUT… the issue is - even on market close time - when doing the same order from the Alpaca Web UI, orders are displayed (at “accepted” state… but at least displayed…).
any help to see what i’m missing will be great.

E.

We had partial outage last week and recovered quickly. As far as we see orders were eventually processed but let us know and send support tickets if you still have issues from this instance. http://status.alpaca.markets/incidents/4pdr8q5trpbr