Unable to Complete Sign Up


For whatever reason, I can’t continue through the Sign Up process.
I’ve tried on mobile, web, and even in Incognito mode.
I’ve also tried different addresses and the Continue button won’t activate.

The Chrome console doesn’t show any obvious errors or issues.

Any help would be appreciated!

Hello @mastermind202,

Unfortunately I don’t have an answer for you, however I’m just here to recommend that you don’t post your personal information here. I would blur it out in the future

Hello @mastermind202

I had the same issue, just use a different browser

For me it was not working with chrome, I used safari and it worked :slight_smile:

1 Like

Hey DMick,

That was actually fake info in the screenshot, but good looking out!

@mastermind202 Are you still experiencing issues signing up for an account. If so, please send a support request to support@alpaca.markets with a brief description of the issue. They should be able to get you up and running.

Hey Dan,

Yeah, I tried multiple browsers and the only way I could finally get past that step was by using a different address. My home address is a new build and street has only existed for a year, so I’m sure that has something to do with it. I’ll email support to get it corrected.