Problems in Web Application?

Hello, I recently signed up for an Alpaca account, and I’m still getting my feet wet in the API and doing some practice paper trading. I logged on this morning to do just that, but the web application seems immensely slow and barely functional. Is something going on?

Opening my live trading account page takes about half a minute to load when it usually takes seconds, and I can’t even get the paper trading page to load. I just want to reset my paper account, but I am unable to do so.

Tested from two different networks and in two different browsers (Chrome and new Edge). Before 9 EST, everything seemed fine, but now it is unusable. Any help would be greatly appreciated. Thanks!

I am having the exact same issue!

Yeah, there was a problem with both their website and API, but it seems to be solved now

1 Like

I am still having problems with the website, and API requests are returning status 500.

1 Like

Also when trying to renew the API key the following error occurs “Could not create new access key
Unexpected token N in JSON at position 0”

I am still having all the mentioned issues and have tried different browsers, networks and computers.

I’m unable to trade as well. From a day trading live stream I am watching it sounds like there are some nation-wide issues and a lot of traders are having problems getting orders filled with many different brokers.

I’m getting the following errors (and this has been running fine for a couple of weeks):
502 Server Error: Bad Gateway for url:
And on a different attempt:
504 Server Error: Gateway Time-out for url:

1 Like

You’ll just need to wait it out. This isn’t on your end. The market is doing crazy things right now that will be written about in history books, and Alpaca must not have been prepared to deal with it.

Looks like this morning Alpaca was not able to handle the order flow. I was hoping they would shine in conditions like today but alas :frowning: they are just as bad as others. In fact, TD worked better this morning which is usually is not the case. Fidelity was the worst of all for me - they could not even load my positions or accept new orders.

Everything should be back up and running. The issue stemmed from Alpaca losing a feed to/from one of our execution partners. This backed up orders being sent to that venue. Our servers slowed down as they were waiting for responses from that venue. Not sure if it was a network problem or something on the execution partner side. This may have been the same issue other brokers experienced?

Sorry for the inconvenience.