Account not authorized to trade after Feb and new API Keys

Im getting this message when hitting the order endpoint from both my apps which I generated new API keys for yesterday. Both accounts worked all February and stopped now. From the header I see that its sending to the correct address. Both accounts hold several 100K and are day trading accounts, why am I not authorized anymore?

2021-03-02T14:27:59.586918+00:00 app[web.1]: error: { code: 40310000, message: ‘account is not authorized to trade’ },
2021-03-02T14:27:59.586918+00:00 app[web.1]: options: {
2021-03-02T14:27:59.586918+00:00 app[web.1]: method: ‘POST’,
2021-03-02T14:27:59.586919+00:00 app[web.1]: uri: ‘’,
2021-03-02T14:27:59.586919+00:00 app[web.1]: qs: {},
2021-03-02T14:27:59.586919+00:00 app[web.1]: headers: {
2021-03-02T14:27:59.586920+00:00 app[web.1]: ‘content-type’: ‘application/json’,
2021-03-02T14:27:59.586920+00:00 app[web.1]: ‘APCA-API-KEY-ID’: ‘mykey’,
2021-03-02T14:27:59.586920+00:00 app[web.1]: ‘APCA-API-SECRET-KEY’: ‘mysecret’
2021-03-02T14:27:59.586920+00:00 app[web.1]: },

i got the same problem too, with no reason.

I have the same problem too. Wish someone from Alpaca team would monitor these forums.

Man I have searched everywhere for this and haven’t found a single solution yet. Is this just not widely used, or like why can’t I find anything recent on here.

The fix for this issue was to send them 5 emails with this issue which they replied to they had to manually authorize the api keys. Few hours later they have been working. Its a pain since March, but you should probably do the same.

Ah ok. Well the way I fixed it was resetting the API keys until the account was marked as active by calling to it with python.

Why am I all of a sudden getting messages “not authorized to trade”? Was working fine yesterday.

I am also getting this issue today after resetting this morning. Anyone have any ideas?

Was having the same problem here, “account not authorized to trade” after resetting the account. Everything got back to normal, just had to wait a bit.

I saw this issue yesterday for about an hour or less before it resolved but now it’s happening again. I cannot place paper trade orders via the API or the web UI and I reset my paper trade account last night.

The Alpaca API status page indicates everything is functioning normally so I’m guessing Alpaca staff are unaware of it.