Order not Created - Account not authorized to trade

I’m trying to place an order in my paper account; however, I keep receiving the error, “Order not Created - Account not authorized to trade”. This error started showing up on Monday after I reset the account and generated new API keys. It fails whenever I attempt to place an order in my Python microservice and the Alpaca UI. Can someone please assist? I haven’t been able to trade and test for nearly a week now, and it’s beginning to be frustrating.

Thanks,
–Ellias

1 Like

Same thing on my end, getting an “Account not authorized to trade” error on the paper account. This has worked from months, must be a recent issue after an account reset. Tried to reset several times as well. Is this related to having to switch to the 2.0 API now?

This was all fun and games with getting no support while everything was free, but now that I’m having to actually pay for a subscription I expect some kind of support and replies when shit doesn’t work.

Alpaca - Time to start caring or I’ll switch my API to TDA!

1 Like

I also can’t trade with my paper account anymore after resetting. But I get a HTTP 403 Forbidden message back. Please fix this:)

I have the exact same issue. Too many users in too short a time to have it be anything but an Alpaca software issue.

1 Like

same here, can’t even trade through chrome web or api

Same here, not working for me either. “Account not authorized to trade” after working for several weeks. Suppose you get what you pay for.

Hey y’all,

So I was eventually able to get it resolved. Whenever I accessed my account details through the Python API, the status was ‘SUBMISSION_FAILED’. So basically, whenever you reset the account or generate new keys, I’m assuming this would result if something goes wrong in the Alpaca back-end. To resolve this, I just kept regenerating keys (or kept resetting the account, I honestly can’t remember) until the account status changed to ‘ACTIVE’ in the Python API. It took several tries to get it all working. Hope this helps!

Thanks,
—Ellias

2 Likes

I get “Order Not Created forbidden.”
But my account does not have issues.
Can someone help me with this?