Wise money app and ACH

Recently I signed up to Alpaca and used my Wise ACH bank details to fund the account. At this moment, Wise are in the process of some sort of routing number conversion with the result that each customer such as myself, has two US routing codes and account numbers for their USD account. For simplicity these are referred to the old and new ACH details, with customers encouraged to use only the new version.

So when I went to use the new details to fund my account Plaid would not accept them. I tried a few times, making double, and treble sure I was copy/pasting (and manually inputting) correctly. No way, no how.

I tried the Wise “old” ACH routing and account number, and presto, it worked! I was a happy camper and put $20 into the account so I could get access to some API data to start off on my adventure. That was duly credited to my account and was followed by a further pleasant surprise of an additional $5 credited to my account as a bonus by your good selves. $25 showing on my Alpaca Dashboard. Happy Days.

But then…I got a notification from Wise that my $20 debit had been cancelled, as the old account should not have been used but rather, the new account and routing should have been selected. “but I tried all that yesterday or the day before and it didn’t work”, I thought to myself, fearing that my funding door was about to be slammed shut and little I could do about it.

But, “I’ll try again”, I thought, as perhaps my transaction had triggered something somewhere, and some cobweb got blown out of the way of the cogs. So using the new account I completed the link process with Plaid, and this time it did work! So they all lived happily ever after right?

Well, not quite.This time I added $11 from Wise, just to get over the $10 minimum to get access to API data for a longer period. And that duly arrived today, but when I look at my Dashboard, my equity has gone from being $25 in credit to -$9 negative. $20 of that $25 I understand, as it was returned to Wise for whatever ACH issue there originally was, the $5 bonus just disappeared I guess, so I should have at least $11 credit in my mind.

But it’s -$9. It appears I have been hit with a $20 charge for the returned ACH. And on top of that I’ve lost that $5 bonus. I think I should be $16 in credit, but it’s $9 in the hole, without as much as a sniff at any data, much less an actual trade. Not an auspicious start, and I feel that any issue that led to this situation was not of my creation yet I’m the one feeling the brunt of it.

Could this please be rectified? I’d be very grateful. Thank you for your time.