Rapyd doesn't work for me

I am from the Netherlands and I want to fund my account. I tried Rapyd but it doesn’t work for me. Ik can select my country and my bank but when I try get : No Payment Options for this selection.
What’s wrong?

Same here, trying to deposit from the Netherlands using Rapyd- same error. Please advise.
Many thanks!

From italy tested with Rapyd and i have the error “An error occurred while initiating your transfer.”

From Netherland, Getting same error with Rapyd any updates?

Hello! Mahmoud here, product at Alpaca. Apologies on the issues you are seeing with Rapyd. As of now we are facing some problems with our integration with Rapyd, which can affect some countries.

On the bright side :slight_smile: we are ready to launch a brand new way to transfer funds! Would you be interested in joining our private beta? Please fill out this form and someone from the product team will reach out to you with more details!

1 Like

Hi Mahmoud,

Certainly, I am interested in beta testing the funding alternative! I filled in the form. Can you give me some more details on the mechanism? Besides security the costs of the alternative should be limited. To be honest, the 1,5% of Rapyd didn’t make it a serious option to fund using higher amounts.

regards, Steven

Thanks @mahmoud_alpaca - I just filled out the form. As a UK citizen/resident, I would love to have more options for transferring funds.