Alpaca-py getPosition not returning crypto pairs formatted as ETH/BTC

I’m using Paper Trading and the below code to pull current position of a pair.

Using “ETH/BTC” and “ETHBTC” as the pair for the request but neither returns the position. I have 3 positions open in ETH/BTC I can see on the web portal.

It does work with ETHUSD and BTCUSD nut not cross pairs

I’m using bot the JS module here

async function getMyPosition(){

    try {
        await client.getPosition("ETHBTC").then( (data) => {
            res = data;
            // positionQuantity = data.qty;
            // positionValue = data.market_value;

    } catch (error) {

For python I’m using alpaca-py SDK. It returns all current positions but NOT the ETH/BTC open positions

def get_all_assets(self, user_asset_class):

        search_params = GetAssetsRequest(asset_class=user_asset_class)

            assets = self.client.get_all_assets(search_params)
            for asset in assets:
                # print(type(asset), '\n')
                # print(asset, '\n')
                print(f"symbols: {asset.symbol}\n")

        except Exception as e:
            print("There was an issue getting trade quote from Alpaca: {0}".format(e))
            return False

        return assets

![Alpaca Position Return|466x500](upload://rXH1gMVu4NqamUmoBRvhsGn0evc.png)

I use the python client and have the same issue with get_open_position

I noticed that when i get all postions, my positions are listed using the old style symbol (ie: BTCUSD instead of BTC/USD).

When I tried using BTCUSD with the position call, it worked for me.


And none of the Crypto Cross-Pairs are working for the Streaming data service.

Also customer support hasn’t responded yet!