1Day missing in GET/v2/stocks/{symbol}/bars

Hi guys

“1Day” is missing in GET/v2/stocks/{symbol}/bars. I tried “1D”, “day”, “1Day”, none of them works. “1Min”, “15Min” work fine.

It returns empty list. Please help and look into this.


Hi @Jn_Zhou,

Can you please paste your exact request here?



for daily bar:

params = {“start”:“2020-09-01”,“end”:“2020-10-02”, “timeframe”:“1Day”}
requests.get(bar_url, headers=login_header, params=params)

where bar_url is https://data.alpaca.markets/v2/stocks/amzn/bars
login_header has same key/secret as in 15Min request.


Hi Alpaca team:

Can you look into this? I tried with different starts and ends, with or without limit, so far no luck. again, 1min, 15min, 1hour all worked fine. I wonder anyone has the same problem. It’s supposed to be a basic use case, it’s unlikely I have it configured wrong. The lack of response from Alpaca team is even more interesting.


Hi @Jn_Zhou, we’re sorry for the delayed response.

Have you tried /v2/stocks/AAPL/bars?timeframe=1Day&... ?

Please submit a support ticket to support@alpaca.markets if you’re having issues.