1Hour missing from v2/stocks/{symbol}/bars

Hi folks, just getting started with a paper account, noticing that with the below endpoint, 1Min and 1Day work fine, but 1Hour does not (“invalid timeframe”). Has it been renamed? Is there another (free) endpoint where I can find one hour bars?


Or, if 1Min is my best option, how do I get more records than 1000–tips on how to get multiple pages and assemble into one dataframe would be greatly appreciated.

Many thanks

1 Like

I think in v2 the hourly timeframe has the value of 1Hour

Thanks Chris, but I believe I’ve tried this, and I got “invalid timeframe” --would you mind posting your specific endpoint, where you’ve found 1 hour bars? That would be amazing!

From the docs - string

One of minute , 1Min , 5Min , 15Min , day or 1D . minute is an alias of 1Min . Similarly, day is of 1D .

no 1hour. It would be nice to have 30min and 1hour.


Hi Guys,

1Day is missing from v2/stocks/symbol/bars. I tried “1D”, “day”, “1Day”, none of them worked.