Websocket stopped sending bars

Did anyone else’s AM.* websocket just completely stop sending data? It acknowledges my subscription request, but I’m not getting any data…

Well I just tried to switch to the V2 Public Beta (was v1 deprecated? no one ever responded to a forum post asking that…) and this API is extremely flaky, auth only works every now and then, and now I’m getting [%{“T” => “error”, “code” => 400, “msg” => “invalid syntax”}] on my auth message that worked half an hour ago.

I have to say, this whole market data rollout is extremely unprofessional and I think I will just have to retrofit my code to call Polygon directly.

Hi @Sam_Brotherton,

We had a networking change misconfiguration within our data infrastructure lead to 25 minute downtime for both internal and external market data services.

See the incident on our status page here.

Thanks Abel! So would you recommend staying on the V1 datastream for now or migrating to V2? It was unclear to me whether V1 was getting turned off, and if so with how much notice.