Trading View Problems

When I try to log into alpaca on tradingview, It keeps saying that it has timed out and to please try again. I tried to revoke and readd trading view on 0auth apps but I am not sure what details to put on it. Any idea of what I should try so that I get tradingview to work with alpaca?

we don’t know… don’t bother us…

@justdrew2u Do you see an Alpaca tab at the bottom of the TradingView chat similar to this?

If so, click on the tab. You may need to refresh your browser page?

If not, you will need to re-link your Alpaca account. There are instructions on how to do that in this tutorial.

Does that help?

No it didn’t fix the issue. Don’t you guys have a chat feature, email, or customer service number? Furthermore, I cancelled an order but it still executed which I don’t really understand. Also, you aren’t allowed to establish take profits and stop loses in tradingview on Alpaca? Why not?

Also the issue that fixed it was after I scraped on your website in the forums for quite a long time because I didn’t get help and saw that it was an issue with 2PA, but that flaw should really be fixed with the software team as I always use 2PA even in tradingview.

@justdrew2u TradingView is really who should be contacted for any issues or questions about which order types are supported with that integration. We try to help but all we can really do is ensure our APIs work.

As far as an order being being executed. One can request an order to be cancelled but there are no guarantee orders can always be cancelled. It’s an asynchronous process and an order may be too far in the execution process to cancel. If there is a specific order you wish more info on please send a note to Include the order number.