The API get_last_quote is returning zero ask/bid prices

The get_last_quote API endpoint is returning 0 for all fields except askexchange and bidexhange. Is this a bug, or am I missing a trading fundamental? This data is from around 9:45am MAR 5 2021 for the symbol ACIC:

{
  'askprice': 0,
   'asksize': 0,
   'askexchange': 15,
   'bidprice': 0, 
   'bidsize': 0,
   'bidexchange': 15, 
   'timestamp': 1614955655735614011
}

I noticed ACIC has an ACIC.U counterpart, are the 0 prices related to a different market? I’ve been seeing this on a handful of trades, where I get a zero value back, but I haven’t dug into the others yet

EDIT: I’m using the Python Bindings, if that matters.

2 Likes

We are experiencing the same. Quote data is completly off, sometimes lagging or like in your case 0 which lead into wrong quantity calculations and insufficient buying power error responses. I am waiting for them to have this fixed.

1 Like

Same problem here. I guess to fix these mistakes which are costing money to users is not a high priority @Alpaca.

1 Like

I think I’m having the same issue, I’m getting a 404 error back

I dont get a 404 I get a result but the values are not correct. I also tried fetching like AMD and bid and ask were 0 lol.

Ya, the second time I went in I didn’t get 404, but it did give me 0 for ask and bid. Looks like it’s working this morning.

I still get this for NVDA right now which is wrong
{
“status”: “success”,
“symbol”: “NVDA”,
“last”: {
“askprice”: 592,
“asksize”: 1,
“askexchange”: 15,
“bidprice”: 490,
“bidsize”: 2,
“bidexchange”: 15,
“timestamp”: 1615388153053097200
}
}

As of right now, a quote request for MSFT returns the same information as @bdavis9d posted – although it has a more current timestamp.

Alpaca is becoming just about useless without Polygon or a stable source of data… :confused:

Been having the same issue. I only trade daily, so the best work around I’ve been able to make in python is something like below…

account = api.get_last_quote(ticker)
    if account.bidprice == 0:
        account = api.get_barset(ticker,limit=1,timeframe='minute')
        account.bidprice = account[ticker][0].h
2 Likes

Nice, I think I’ll borrow this, thank you!!

1 Like

I had the same issue today. I’m astonished after 3 months, Alpaca has not resolved it! It’s very critical issue.

@Amir Question, which Alpaca data plan are you subscribed to? Th ‘Free’ plan includes only those trades and quotes which executed on the IEX exchange. If there hasn’t been a NBBO quote for the current day on IEX then that bid or ask price will be 0.

I had the issue with paid data plan and API V2.

Still experiencing this issue, now in November. Does @Alpaca ever intend to respond to these issues? Or are we on our own here?

I’ve tried buying the $10/month for Finra and Nasdaq data on top of the free IEX data, but so far I see no difference in data quality.

Clever. Having read this, it seems so obvious to me now. Thanks.