Pylivetrader install fails in Anaconda on Mac

When I try to install Pylivetrader in Anaconda on Mac, the install fails with following message. I created separate environment with Python 3.5, 3.6 and 3.7, the pylivetrader install fails on all listed versions of Python. I tried installing both through Anaconda Navigator and through Terminal command line. Both failed. Also, alpacahq channel shows pylivetrader version 0.0.29 in Anaconda.

UnsatisfiableError: The following specifications were found

to be incompatible with the existing python installation in your environment:

Specifications:

- pylivetrader -> python[version='2.7.*|3.4.*|>=2.7,<2.8.0a0|>=3.7,<3.8.0a0|>=3.8,<3.9.0a0|3.3.*|3.6.*']

Your python: python=3.5

If python is on the left-most side of the chain, that's the version you've asked for.

When python appears to the right, that indicates that the thing on the left is somehow

not available for the python version you are constrained to. Note that conda will not

change your python version to a different minor version unless you explicitly specify

that.

The error message with Python 3.6 is slightly different.

UnsatisfiableError: The following specifications were found to be incompatible with each other:

Output in format: Requested package -> Available versions

pip install pylivetrader also failed on a new dedicated virtual environment with Python 3.6.10.

ERROR: Could not build wheels for bottleneck which use PEP 517 and cannot be installed directly

Separately installed bottleneck using conda and then tried installing pylivetrader, failed again

error: command ‘gcc’ failed with exit status 1

ERROR: Command errored out with exit status 1: /opt/anaconda3/envs/alpaca/bin/python -u -c ‘import sys, setuptools, tokenize; sys.argv[0] = ‘"’"’/private/var/folders/z1/_pr76nzn5v3bhlxfs7m_pygc0000gn/T/pip-install-rfjzh7wb/cyordereddict/setup.py’"’"’; file=’"’"’/private/var/folders/z1/_pr76nzn5v3bhlxfs7m_pygc0000gn/T/pip-install-rfjzh7wb/cyordereddict/setup.py’"’"’;f=getattr(tokenize, ‘"’"‘open’"’"’, open)(file);code=f.read().replace(’"’"’\r\n’"’"’, ‘"’"’\n’"’"’);f.close();exec(compile(code, file, ‘"’"‘exec’"’"’))’ install --record /private/var/folders/z1/_pr76nzn5v3bhlxfs7m_pygc0000gn/T/pip-record-xdbtacqi/install-record.txt --single-version-externally-managed --compile --install-headers /opt/anaconda3/envs/alpaca/include/python3.6m/cyordereddict Check the logs for full command output.