Alpaca Data Streaming Client is Unauthorized. Connection Limit Exceeded

I have been getting this really strange error/issue on multiple paper accounts where Alpaca Streaming Client connects and authenticates just fine but the Alpaca Data Streaming Client doesn’t connect and authenticate properly and gives me the connection limit exceeded error then proceeds to be stuck in an endless loop of errors because of the previous issue I reported with the reconnection. This is an account that was reset twice with brand new API info btw.

Here is my console printout:

Waiting for market to open…
Market opened.
Alpaca streaming client socket opened.
Alpaca streaming client connection status is Authorized.
Alpaca data streaming client socket opened.
Alpaca data streaming client connection status is Unauthorized.
Alpaca data streaming client error:
Exception Type:
Alpaca.Markets.RestClientErrorException

Exception Message:
connection limit exceeded

I only started getting these errors after the switch over to the new v2 data. I have some paper accounts that work perfectly and some that give this error but with this error, I can’t buy or sell any stock so it is a vital issue for me

Getting same problem when trying to “authenticate” using the V2 streaming client. Getting the following message when trying to authenticate:\

[{“T”:“error”,“code”:406,“msg”:“connection limit exceeded”}]

Same error for both paper and live API keys.

I just randomly started receiving this error as well.

[{“T”:“error”,“code”:406,“msg”:“connection limit exceeded”}]

The docs say this error occurs when “You already have an ongoing authenticated session” but I don’t have any sessions going.

Update: I waited overnight and it resolved itself. I’m assuming there’s an internal timeout or something. It would be nice to have a way to force all authenticated sessions to terminate.