Problem with importing module

Hi I got the "

ModuleNotFoundError: No module named 'alpaca

I’ve tried to install the package with the command " pip3 install alpaca " and I can see clearly that it has been installed but I keep getting that Error
tried to google it but nothing helps


I encountered the same problem at first.

Make sure you are using the right version of python when running your program.

First I would run the following commend:

pip3 --version

This output which version of Python is associated with pip3. That is the same version of Python that the script/program should be running for it to work.

So if you installed alpaca-py for Python3.9, but your program is set to run with Python3.8, it will not work.

EDIT: I want to clarify as well. When you did pip3 install alpaca that won’t work. The module name is alpaca-py Make sure you run pip3 install alpaca-py

Thank you for that answer!
I run that command the got that my python’s version is 3.10
and I made sure that I wrote it right.

And I found out that if I code through Visual Studio Code it works fine. but when I code on Pycharm or Jupiter Notebook it doesn’t.
I got really confused about that problem

Edit :
I’ve updated the version of my Jupiter and that solved it, but on Pycharm it still doesn’t work
guess I’ll code on visual for a while :sweat_smile:

Glad you got it sorta working. I code on PyCharm primarily so I remember having to change and mess around with some settings for the virtual environment (venv) to get it to work properly.