No SIP quotes at all for any stock on 2/24/22

I could not retrieve any historical quotes for 2/24.

For example:

Changing the date there-within to another (e.g. 2022-02-23 or 2022-02-25) would produce data.

  1. Can anyone else get any historical quotes for 2/24?
  2. Why does the API status tracker ( claim that this endpoint was working on 2/24?

Hi martingale, all date time type inputs and outputs are serialized according to ISO8601. E.g. … v2/stocks/SOHU/quotes?start=2022-02-24T0:00:00Z&end=2022-02-24T11:00:00Z

ref: Trading API | Alpaca Docs

Thanks for replying Waimun.

But I don’t understand your point(s). Are you saying my URL syntax is wrong? Are the “start” and “end” parameters in my example not already ISO8601?

Did you try the API and actually get any quotes for that day (for any NMS stock)?


Apologies on my part. The start and end date is correct.

Tried /v2/stocks/quotes?start=2022-02-24T0:00:00Z&end=2022-02-24T23:00:00Z&symbols=NMS with other symbols like NMS & AAPL, I am able to get the quotes.

However for the symbols SOHU, the quotes are limited.

Thanks Waimun. Could you try with another parameter “&feed=sip” included? I have a feeling you were trying with the IEX feed only.

Later today, I will also re-run my examples with “&feed=iex” to see if I can get anything. I cannot do it right now.

I should have been more explicit that I was complaining about SIP feed. I modified the thread title accordingly. Thanks for making me more precise at least.


martingale Tried with additional parameter “&feed=iex” … I got quotes response

Above is my query string for your reference.

No worries, here to help. :bowing_man:

Thanks. You meant “tried with additional parameter &feed=sip”, as that is what your URL indicates.

I will try again later today. Could you copy/paste a few quotes you got? Thanks.

Better yet, could you capture the output (for example redirect to a file “>nms.out” on your computer terminal) and attach the file?

The reason you got any quotes at all, was merely due to your start-date being 2022-02-23. In my OP, I already mentioned → Changing the date there-within to another (e.g. 2022-02-23 or 2022-02-25) would produce data.

So my original claim stands.

Hi @martingale

The missing due to our data provider ICE having a technical problem beginning at 3:30 on 2-24-2022 which lasted the rest of the evening. We didn’t get any data on tapes A and B. We’ll need to go and backfill the data but not there yet. See the incident report here Alpaca Status - Data from tape A/B not updating., and we are working on this, we will let you know once is completed.

apologies for any inconvenience caused.

Thanks Masjaya, for looking into this.

So you do get your data directly from UTP and CTA?

FYI, as of now, it seems I could retrieve trades for that day for all three tapes (based on spot checks).
But no quotes for any tape. (Nothing for C tape either, as I tried AAPL).