Live Account not Authorized to Trade

My Live account wont let me trade. Also, the Live part is not showing up in Tradingview. Why would this happen? Its kinda messed up.

1 Like

I was being impatient. :frowning_face: I have been using Alpaca for almost a year, but i had to wait for some kind of account approval after switching to the new API

I am experiencing “account is not authorized to trade” aftr I regenerated my API keys today. I initially thought that was the error cause I had before but it wasnt. Now with then new API keys I am apparently not authorized anymore to trade.

Did the same occur to you when you made a new API key or when did you get the error? Also, how long did it take to get this fixed, did you have to get in touch via support?

1 Like

I never changed my API keys. When I tried to trade this morning it wouldn’t let me. I signed up yesterday 02/28 around 10:30 AM EST and couldn’t trade until 03/01 11:00 AM EST. So, looks like a 24 hour thing. I did not contact support directly.

Thank you mate. Yea I dont remember how it was when I first created an account, if I had to wait as well. I think it could be related that I just regenerated an API key and that for I am still not authorized. I Appreciate your quick response.

1 Like

I have this problem with my paper account… I can’t even trade through the chrome web.