Invalid Polygon credentials?

Invalid Polygon credentials, Failed to authenticate: {'ev': 'status', 'status': 'auth_failed', 'message': 'authentication failed'}

using the code from here:

to authenticate, I have been using:
os.environ[‘APCA_API_KEY_ID’] = ‘XXX’
os.environ[‘APCA_API_SECRET_KEY’] = ‘XXX’

everything has been working fine for weeks up to last Friday.

Do I need to regen keys or is something broken on alpaca’s end?
btw, I have checked and everything is green.

Okay - it appears to be up now (Monday 4:30PST) - must be a system reset or something.

At 12:37PST, I’m getting the exact same error again.

This Polygon interface seems really flaky (after being solid for weeks). Anyone know what’s going on?

I’ve also had the same error and issue pop up today. I’ve only been using the Alpaca’s interface to Polygon for a week or so now, but the same key and secret key were working fine previously. Thinking this might be on the server side.

I have got it also:
Invalid Polygon credentials, Failed to authenticate:
Reset keys, but that did not help.
Can’t work without feed.
Any suggestions for alternate.

I get the same error when attempting to open a stream. The Polygon API seems to be okay when calling for ticker or aggregate data so the situation maybe isolated to just the streaming part. Unfortunately the status pages doesn’t track the status of their streaming service:

We got a response from alpaca!

Keep an eye out on github for an update.

Hello guys, sorry for trouble but we have deployed the new code to address the issue. Let us know if you still see the issue. The streaming should work fine with your paper API key if you have live trading account. Keep in mind the concurrent streaming connection for polygon is limited to one at a time.

Confirmed. It’s up and running without any code modifications on the client side as of 16:05 PST. Thank you!

Is the concurrent streaming connection for polygon is limited to one at a time for paper and live or just paper?

Hi all. This problem seems to be back again: no code changes, but invalid credentials despite using the same live key. It was running fine this morning and then stopped a little after 11:30 AM EST.

I used the code from\

I created key_id and secret_key on Alpaca Dashboard.
I don’t have live trading account.

args.key_id = ‘PKKZYL5NHY81YGMFDP53’
args.secret_key = ‘HeuDduUJt8kG2UqFrETG7a7N3T7K1Tp5Rzw2UdKg’
args.base_url = ‘

Error is like below:
ValueError: Invalid Polygon credentials, Failed to authenticate: {‘ev’: ‘status’, ‘status’: ‘auth_failed’, ‘message’: ‘authentication failed’}

Any help is appreciated.

Because you need fund account. I had similar problem and can’t test it too.