Alpaca web sockets & Go Lang SDK

I’m using Go lang sdk v2.5.0 and can’t establish a socket connection. Following an example here alpaca-trade-api-go/data_stream.go at master · alpacahq/alpaca-trade-api-go · GitHub but keep getting disconnected:

2022/06/06 14:59:21 INFO datav2stream: connecting to wss://, attempt 1/20 ...
2022/06/06 14:59:21 INFO datav2stream: established connection
2022/06/06 14:59:22 INFO datav2stream: finished connection setup
2022/06/06 14:59:22 INFO datav2stream: disconnected

Same when I specify a sandbox URL for streaming. Tried regenerating new API keys - same result. I should also mention that sockets work when I use an old version (1.9.0) of the SDK. But once I switch to the newest one - keep getting the errors above. What am I doing wrong?

anyone? Does Alpaca have support members browsing this forum here?

Are you on the free market data stream or the paid ($9/month)?

I’m on the paid account. And it works fine with the old version of the sdk (v1.9.0), but just keeps disconnecting when I switch to the new one. I tried regenerating the API keys for both live and paper account - didn’t help. Debugged and made sure the API keys are actually being used as well, so I don’t think it’s that.

Hi @Xpolg

can you give me a little more context on the situation? When did this issue begin happening? Has it been occurring consistently, or does it happen on and off? could you try to get all packages from here and it would be great to find a more personalized solution I suggest sending the email to