2FA Codes Not Sent

When I try to log into my personal and broker accounts 2FA codes aren’t sent to my device. They’ve worked until today.

Similar issue from December: 2FA/MFA SMS codes not being sent

Hey, @tbliu!
Thank you for raising this!
We are investigating the problem and will solve it as soon as possible.

Hey, @tbliu.
For this moment, 2FA codes delivery works well.
Please, try to sign in once more. If you face difficulties after a few attempts, contact Alpaca support via email: support@alpaca.markets.

Thanks for responding @Max_Alpaca; it’s working for me now. Maybe it was just an issue with my phone.

MFA/2FA/SMS Verification Code not sent to my phone. Here are the details:

  1. I just applied the “live account” about 7 hours ago
  2. After that, I request a bank transfer and enabled “MFA text code”. I did received the code to enable this function. ( that is, my phone is work, my internet is working, and my phone number is valid and correct.)
  3. But after that, I tried to log in from other computers, Alpaca requires “MFA text code”, but never sent me one. So I could not log back in from other devices.
  4. I still have one live login from the computer I used last night. I tried to disable the “MFA security” from there, but it requires “MFA text code” as well. It is a dead lock.
  5. Unfortunately, I did not save “recovery code” when I enable “MFA security”.
  6. Since my account was applied last night, it is still in “pending approval” status. Is it possible that it is the reason for not sending “SMS code” to my phone?

Please help. Thanks

Thank you for raising this!

While you are using SMS for MFA code delivery, it’s possible to have some delay in the code transport service.

Possible actions are

  • wait a bit for transport, consider you have a working session
  • contact Alpaca Support via email to restore access to your account (it could take a few working days)

Thanks, @Max_Alpaca. I sent an email with my account information to Alpaca support. Hope they will fix the issue.

1 Like

For security reasons, I’d suggest you all use the TOTP option (i.e. Phone Authenticator) rather than SMS. Would prevent this issue from occurring as well

1 Like

Thank you for your advice, @vagrand. I will switch it to Authenticator once I get back access to my Alpaca account.