Just started out, keep getting http status 403 forbidden

I recently registered on alpaca, created an oauth test app registration, sent the requested email to have my test application enabled, tried contacting support to know where app enablement stood but got no reply, received today an email from alpaca support saying “you are almost there” (nothing else to clarify what this means), I tried once more to make a simple call to the account endpoint (i.e. https://data.alpaca.markets/v2/account) sending in the http headers the client id and secret for the oauth application I registered and I keep getting a 403 forbidden response, no other detail as to why my call is rejected. I don’t even know if the oauth app I registered is enabled since this information is not provided on the website. For now my experience in testing out this api is frustrating.

1 Like

It took a few days to get my account fully working, and now the paper trading works great.

Yes, a few days have already passed. That is exactly why I was wondering what that “you are almost there” email I received meant.

10 days and my oauth app credentials still get a “forbidden” response. Never seen anything like this with users mostly abandoned to themselves with zero support and zero replies to emails. Is it because I’m not a paid user? Well I will never even consider any paid service considering what I’m experiencing.