Crypto trade Stream not working

I’ve been using Crypto stream for more than a Year, but since the new update to v1beta3 there is no incoming data from the trades subscription. I’ve tried with alpaca API, pythom Websockets and wscat websocket connection and not working. When I change to subscribe for quotes, for example, it is fine.

1 Like

The number of trades happening on our Alpaca Exchange is rather low at the moment. It’s not zero though. If you wait long enough and subscribe to popular crypto pairs, you will see trades on the stream. You can use the historical API to verify.


I understand. I subscribed to more than 15 figures Alpaca support and no trade in more than 30 minutes.

Thanks for the answer. Makes sense.

I experienced the same issue.
Does any subscription required to get streaming data?

@Tokusuke_Utsugi What error messages and/or symptoms are you experiencing? Can you connect and authenticate. What symbols are you subscribing to? That would be a good starting point to help debug.

1 Like

I was able to get it working both by using the API and creating the functions myself. Can you share your code?

1 Like

Thank you all,
Now it works for me too.
Appologies taking your ntime.