API throws error. Request is not authorized

I have been paper trading for some time now using an app I am testing.
Recently the app has been throwing an error having to do with the API key.
I updated the api keys thinking that was the issue and I still get errors.

So I tried using postman using new keys and I get this error:

{
“code”: 40110000,

"message": "request is not authorized"

}

What does it mean? Is this a technical error? A formatting error? An issue with my alpaca account? How do I fix this problem?

Anyone from Alpaca support have any ideas?

Is alpaca technical support not on this board???

I get this message too. Followed the exact instructions at Manually Trading Stocks Using Postman and the Alpaca API and didn’t get very far

I’ve started getting this error today (have not made any alpaca calls this past week). Is everyone getting this issue, is anyone NOT getting this and IS able to make alpaca calls normally? It arose specifically when I used the .get_calendar() method

I resolved my issue, i was pointing to an old dns server. Realized it was a “my problem” when some other api calls to other platforms were not functional.

i get “auth failed” when trying to subscribe to WSS

I cannot even log in to my account

You have to be logged into a live account. I got this same error when I specified paper. But live worked fine.

Code will be: https://api.alpaca.markets
Not: https://paper-api.alpaca.markets

2 Likes

Worked for me too! Thanks @JeremyWhittaker!
Just used in Python,

api = REST(APCA_KEY, APCA_SECRET_KEY, "https://api.alpaca.markets ")
api.get_clock()

P.S. Make sure that the keys are from live trading

was this ever resolved? i’m having the same issue as op

Make sure you are using the Paper trading Key secret pair not through the OAuth Apps tab, this only works for live accounts. You can find the key/secret in you paper trading account under “Your API Keys”. Then make sure you use the https://paper-api.alpaca.markets/ endpoint.

Hi. I just ran into this and fixed it. When paper trading, the underscores in the key names turn into dashes. I assume this is so you don’t accidentally switch between paper and real mode. for instance:

APCA_API_KEY_ID becomes APCA-API-KEY-ID

Using underscores didn’t work for me. BUT switching to the Paper Trading (Drop down just under the Alpaca brand) and creating an api key there did.