Alpaca Historical AAPL Minute Data Errors


I’m new to Alpaca. I’ve been using it to get historical data and help me backtest in python. I noticed there seems to be a discrepancy in the data between Alpaca and TD Ameritrade/Google. For example I am looking at AAPL minute data on 2020-01-29. When I query Alpaca for the data I get values in the $300 range, but that does not line up with TD Ameritrade/Google. Google doesn’t show minute data but the daily price seems to line up with TD Ameritrade

Alpaca Vs. TD Ameritrade

Since I’m in python I tried to not use the python Alpaca API to see if the issue may have been in there. When I queried directly instead of using the API I still got the same results.

Do you see anything wrong I may be doing? It looks like the data is just off by a constant scalar ($242.93 by my estimate) since the minute data lines up relative to the other candles.



Hi @Dan, please try using the adjustment parameter on the bars endpoint with value all. This will return split and dividend adjusted data.

I tried out all, dividend, split, and raw and the one that matched the TD Ameritrade historical chart was split so I will use that one. Thank you for your suggestion! :slight_smile: